Posted by administrator

Die Arculus WalletTM App ist derzeit mit Android Version 9 und höher kompatibel und sollte auf jedem Android-Telefon funktionieren, das NFC unterstützt. Für Apple iOS funktioniert die Arculus Wallet App mit iOS Version 10.0 und höher, es werden jedoch nur iPhone 7 und neuere Modelle unterstützt.